openwrt TPLINK 3220

8:39 PM
  1. Chipset
     RAM
     ROM
     BUILD
     Upgrading From TPLINK Admin Panel
     MR 3220 V.2 OpenWrt LuCi Interface
     Wifi menu
     WiFi
     Block Mount

    Download firmware here:
    https://www.box.com/s/cqk23ztqlux1zs034896

  2. Aplikasi WebCam

    drivers
    #opkg update
    #opkg install kmod-usb-core kmod-usb2 kmod-video-core
    camera driver:
    #opkg install kmod-video-gspca-core kmod-video-gspca-xxx
    simpan:
    #opkg install libpthread zlib libjpeg libfaad2

    FSWEBCAM
    modul
    #opkg install fswebcam
    simpan file:
    #fswebcam /tmp/a.jpg

    Bahan yg digunakan dlm ujicoba:
    1. kmod-video-gspca-spca506
    2. kmod-video-uvc
    3. usbcam

    Deskripsi Driver:
    http://www.ideasonboard.org/uvc/
    http://linuxtv.org/wiki/index.php/Gspca
    http://linuxtv.org/wiki/index.php/Webcam_Devices

    WIKI:
    http://wiki.openwrt.org/doc/howto/usb.video

    Link:
    http://www.facebook.com/groups/openwrt/doc/343632519011112/

  3. config 'interface' 'loopback'
    option 'ifname' 'lo'
    option 'proto' 'static'
    option 'ipaddr' '127.0.0.1' option 'netmask' '255.0.0.0'

    config 'interface' 'lan'
    option 'ifname' 'wlan0'
    #option 'type' 'bridge'
    option 'proto' 'static'
    option 'ipaddr' '192.168.1.1' option 'netmask' '255.255.255.0'

    config 'interface' 'wan1'
    option 'ifname' 'ppp0'
    option 'device' '/dev/ttyUSB0'
    option 'service' 'evdo'
    option 'proto' '3g'
    option 'apn' 'smart'
    option 'username' 'smart' option 'password' 'smart'

    config 'interface' 'wan2'
    option 'ifname' 'eth0'
    option 'type' 'dhcp'
    #option 'proto' 'static'
    #option 'ipaddr' '192.168.1.1' #option 'netmask' '255.255.255.0'

    /etc/config/firewall
    config 'zone'
    option 'name' 'internet'
    option 'network' 'wan1 wan2'
    option 'input' 'REJECT'
    option 'forward' 'REJECT'
    option 'output' 'ACCEPT' option 'masq' '1'

    config 'forwarding'
    option 'src' 'local' option 'dest' 'internet'

    config 'zone'
    option 'name' 'local'
    option 'network' 'lan'
    option 'input' 'ACCEPT'
    option 'forward' 'REJECT' option 'output' 'ACCEPT'

    Link:
    http://www.facebook.com/groups/openwrt/doc/344479875593043/

  4. Apa itu torrent??? Ane jg kagak ngarti wkwkwkwk... tanya mbah google aja ya xixixix...yg ane tau, dengan torrent kita bs melakuakn file sharing, klu dlm kasus ini disebut P2P/ peer to peer

    ada 2 istilah, menurut ane sangat penting yg mendukung keberhasilan kita melakukan download via torrent:

    1. Seeder : bahasa katroknya= orang yg men-sharing/upload file yg kita butuhkan. semakin banyak keterlibatan seeder dalm 1 file, otomatis semakin cepat proses download. itu jg tergantung koneksi kita

    2. Leecer : orang yg download. semakin dikit semakin bagus. yg pasti harus lebih besar jumlah seeder daripada leecer

    dah dongengnya, klu salah, mohon dimaklum/dikoreksi. SD gx tamat :ngacir............
    ni link andalan ane. mau cari software movie, game/apapun cukup lengkap. so yg pasti sepengatahuan ane tinggal pakai/ full cracked. :)))) 
    http://thepiratebay.se/
    Dengan fitur ini kita bs download file torrrent tanpa melibatkan PC/Lapie, sdh bs bekerja sendiri.Oke langsung ke TKP 

    Packeges yg diperlukan:
    1.  luci-app-transmission
    2.  transmission-daemon -
    3. transmission-web
    berikut tahapannya:


    full size :
    http://a2.sphotos.ak.fbcdn.net/hphotos-ak-prn1/555668_235297186591108_1188676148_n.jpg


    full size :
    http://a4.sphotos.ak.fbcdn.net/hphotos-ak-prn1/553133_235297226591104_349008072_n.jpg


    full size :
    http://a6.sphotos.ak.fbcdn.net/hphotos-ak-snc7/315409_235297236591103_2113426825_n.jpg


    full size :
    http://a5.sphotos.ak.fbcdn.net/hphotos-ak-ash3/599827_235297249924435_1677436827_n.jpg


    full size :
    http://a5.sphotos.ak.fbcdn.net/hphotos-ak-ash3/529506_235297509924409_876796081_n.jpg


    full size :
    http://a3.sphotos.ak.fbcdn.net/hphotos-ak-ash3/600035_235297279924432_1043024001_n.jpg

    by Tisaros Kaskus/Obengkumana

    Link:
    http://www.facebook.com/groups/openwrt/doc/421704707870559/

  5. == Cari /dev/tty dan Perkirakan di tty mana modem GSM anda dapat di kontorol dgn command AT ==
    root@OpenWrt:~# ls /dev/ | grep tty tty
    ttyATH0
    ttyHS0 <= ini chonto modem merek 'OPTION ICON 7.2'
    ttyHS1
    ttyHS2
    ttyS0

    == perintahkan gcom -d {tty modem control anda} ===
    root@OpenWrt:~# gcom -d /dev/ttyHS0
    SIM ready Waiting for Registration..(120 sec max)
    Registered on Home network: "INDOSAT",2 Signal Quality: 14,99


    Link:
    http://www.facebook.com/groups/openwrt/doc/344824192225278/ 

  6. Jika terjadi kegagalan pengaturan atau instalasi suatu paket kadang menyebabkan router tidak dapat diakses baik halaman administrator (http://192.168.1.1) juga melalui console. Kondisi ini dapat diatasi dengan cara sebagai berikut;

    1) Matikan dan Nyalakan Router
    2) Sesaat LED SYS menyala tekan tombol QSS
    3) Kini Router telah dapat diakses melalui TELNET
    4) Login Router dengan TELNET
    5) Ketik Perintah: firstboot
    6) Ketik Perintah: /etc/init.d/uhttpd start
    7) Masuk kembali ke Halaman Admin di browser dg alamat: http://192.168.1.1

    Link:
    http://www.facebook.com/groups/openwrt/doc/343633129011051/

  7. Cara flash firmware melalui telnet safemode dan mengatasi masalah debricking mr3420/mr3220

    ~ஜ۩۞۩ஜ
    A. Router masih bisa di ping
    Jika router masih bisa di ping atau anda hanya bisa masuk melalui telnet atau malah hanya telnet safemode, berarti koneksi ke router masih bisa dilakukan, cara yang bisa dilakukan yaitu flash firmware melalui telnet.
    Contoh masalah : router sy terhapus beberapa file didalamnya, termasuk file untuk bisa konek melalui ssh.


    Langkah-langkah:
    1. Pastikan router anda dapat di ping.
    2. Siapkan file firmware anda, dan ubah nama ke yang lebih mudah, misal openwrt.bin
    3. XAMPP sudah terinstall di komputer anda, untuk linux memakai LAMPP
    4. Masukkan openwrt.bin ke htdocs XAMPP anda
    5. Hidupkan router, kemudian tekan dan tahan qss sampai lampu led sys menyala cepat
    6. Buka putty, isi hostname ip address router anda misal 192.168.1.1, Connection type pilih telnet, kemudian open dan akan masuk ke telnet safemode,


    7. Masuk ke direktori tmp dengan cara ketik cd /tmp/
    8. Transfer firmware code.bin ke tmp dengan cara ketik
    Code:
    wget http://192.168.1.2/openwrt.bin
    Ip tersebut merupakan ip lan komputer anda, bukan ip router.
    9. Flash router anda dengan cara ketik:
    Code:
    mtd -r write openwrt.bin firmware
    dan tunggu sampai router rebooting...
    10. Selesai

    --------------------------------------------------------------------------------------------------------

    B. Router sudah tidak bisa di ping maupun kasus lain atau sampai router anda debricking, kecuali kerusakan hardware !! (tutorial hanya untuk windows, maaf untuk linux saya blm bisa koneksi ca-42nya ke putty slalu gagal)
    Persiapan peralatan:
    1. Persiapkan kabel ca-42, solder, tenol, gunting/tang/pisau
    2. Potong kabel ca-42 dan kupas kabelnya sehingga anda menemukan 3 macam warna kabel yaitu putih, kuning, biru
    3. Buka router, dan solder sesuai dalam gambar (dalam kasus saya mr3420) untuk mr3220 saya kurang tau boardnya, mungkin sama, kalo tidak, bisa cari di openwrt atau di search google



    Persiapan software
    1. putty, http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html
    2. tftpd, http://code.google.com/p/tftpgui/downloads/detail?name=tftpgui_2_1_py25_installer.exe

    Flashing firmware
    1. Pastikan ca-42 sudah dikenali di windows sebagai Profilic usb to serial, perhatikan port com nya
    2. Colokkan kabel ca-42 dan lan ke komputer, set lan ip 192.168.1.27
    3. Buka tftpgui dan klik start dan letakkan file firmware misal openwrt.bin ke root directory tftp atau dengan kata lain buka folder instalasi tftpgui anda di program files > tftp dan letakkan di folder root
    4. Buka putty dan pada bagian category pilih serial pastikan setingan sprti berikut
    +++++++++++++++++++++
    Bits per second: 115200
    Data bits: 8
    Stop bits: 1
    Parity: None Flow control: None
    +++++++++++++++++++++
    5. Kembali ke category session, pilih serial, masukkan port com sesuai dengan port anda, klik open
    7. Hidupkan router, dan akan muncul proses booting, jika sampai ada tulisan "Autoboot in 1..." maka cepat2 masukkan kata tpl
    8. Nah cara flashnya
    +++++++++++++++++++++++++++++++++++++++++++++++++++
    ar7100>
    ar7100> erase 0x9f020000 +0x3c0000
    ar7100> tftpboot 0x81000000 openwrt.bin
    ar7100> cp.b 0x81000000 0x9f020000 0x3c0000 ar7100> bootm 0x9f020000
    +++++++++++++++++++++++++++++++++++++++++++++++++++
    kemudian tunggu proses sampai router anda reboot
    * catatan jika router reboot terus menerus, berarti ada kesalahan dalam pengetikan, coba ulangi kembali, soalnya berdasar pengalaman saya, seperti itu


    ------------------------------------------------------------------------------------------------------------
    -new video debricking-
    masih bingung debricking, bisa diliat di video berikut ini http://youtu.be/d6A8W6xSwKw
    ------------------------------------------------------------------------------------------------------------

    - Kabel dku-5

    credited to : ngelih_tenan

    Link:
    http://www.facebook.com/groups/openwrt/doc/344813748892989/

  8. config redirect
    option src wan
    option proto all option dest_ip 192.168.1.2

    Dari contoh diatas semua traffic dari inet di direct ke IP agan misal 192.168.1.2
    Kalo masih pake fw originalnya , agan masuk ke menu forwarding.terus setting DMZ contreng yang enable.dan masukan IP agan pake sekarang.



    Link:
    http://www.facebook.com/groups/openwrt/doc/343638849010479/

  9. paket yg diperlukan:
    - luci-app-samba
    - samba36-server
    - ntfs-3g
    lakukan tahap2 berikut ini:

    1. edit "/etc/config/firewall" dengan menambahkan baris sbb:
    --------------------------------------------------
    config rule
        option src         lan
        option proto         udp
        option dest_port     137-138
        option target        ACCEPT

    config rule
        option src         lan
        option proto         tcp
        option dest_port     139
        option target        ACCEPT

    config rule
        option src         lan
        option proto         tcp
        option dest_port    445
        option target        ACCEPT
    --------------------------------------------------

    2. edit "/etc/samba/smb.conf.template", menjadi:
    -------------------------------------------------
    [global]
        netbios name = |NAME|
        workgroup = |WORKGROUP|
        server string = |DESCRIPTION|
        syslog = 10
        encrypt passwords = true
        passdb backend = smbpasswd
        obey pam restrictions = yes
        socket options = TCP_NODELAY
        unix charset = ISO-8859-1
            local master = yes
        preferred master = yes
        os level = 20
        security = share
        guest account = nobody
        invalid users = root
        smb passwd file = /etc/samba/smbpasswd
    ---------------------------------------------------

    3. tambahkan pada file "/etc/config/samba" :
    ---------------------------------------------------
    config 'samba'
        option 'name' 'openwrt'
        option 'description' 'openwrt'
        option 'workgroup' 'WORKGROUP'

    config 'sambashare'
        option 'read_only' 'no'
        option 'create_mask' '0700'
        option 'dir_mask' '0700'
        option 'name' 'samba'       
        option 'path' '/mnt/sdb2'   <==== sesuaikan dengan drive yg mau diakses
        option 'guest_ok' 'yes'
    ---------------------------------------------------

    4. tambahkan baris berikut, ke "/etc/rc.local" :
    ---------------------------------------------------
    smbd -D
    nmbd -D

    exit 0
    ---------------------------------------------------
    5. ketik perintah berikut pada "putty" :
    /etc/init.d/samba enable
    /etc/init.d/samba start

    nb:
    Jika drive yg akan kita akses berformat "ntfs", maka kita harus menambahkan command berikut pada "putty" agar bisa full akses (baca,tulis, hapus) :
    umount /dev/sdx*
    ntfs-3g /dev/sdx* /mnt/sdb*

    ket:
    x = ganti sesuai dengan terdeteksinya drive kita, misal "sdb","sdc","sdd" dst.
    * = jika partisi drive "ntfs" lebih dari 1, maka lakukan langkah di atas sebanyak jumlah partisi. tanda "*"(bintang) diganti dengan jumlah partisi

    restart router.

    5. pada windows xp/7 masuk ke RUN ketik "cmd" ,lalu ENTER, ketik perintah :
    ----------------------------------------------------
    net use S: \\192.168.1.1\samba
    ----------------------------------------------------
    FINISH !!!

    silahkan akses di "COMPUTER(win7)/MY COMPUTER(win XP)"

    Link:
    http://www.facebook.com/groups/openwrt/doc/373714092669621/

  10. Di sini saya hanya mau share berdasarkan pengalaman ane yang masih newbie :D

    Ini saya lakukan ketika kebetulan modem saya tidak kedetek di openwrt :(, akhirnya saya coba cara lain*, yakni menggunakan paket2 yang sudah saya download dari repo resmi openwrt.

    -------------
    * cara lain bisa menggunakan copy file .ipk ke dir /tmp seperti yg dilakukan agan Tisaros Kaskus :), kemudian baru install semua file .ipk di /tmp

    OK langsung saja.... ini beberapa langkah-langkahnya :

    1. download semua file yang ada di repo resmi openwrt via laptop/PC

    karena saya pake MR3420 maka saya dowload repo dari link ini :
    http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/

    --------------
    * semua file harus didownload, bukan hanya file .ipk saja
    * cara download bisa menggunakan IDM site grabber
    * install web server lokal di PC/Laptop agan, misal menggunakan aplikasi :
    ------> Appserv (http://www.appservnetwork.com/index.php?newlang=indonesian)
    * simpan hasil download di web server lokal di PC/Laptop agan (misal di C:\AppServ\www\openwrt)

    2. koneksikan PC/Laptop (tempat menyimpan repo tsb) dengan router

    3. ubah isi file opkg.conf sehingga menggunakan repo lokal di PC/Laptop tsb

    - ssh ke router
    - vi /etc/opkg.conf
    - ubah link menuju repo openwrt sehingga menuju ke repo lokal
    contoh :
    ubah link ini : http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/
    menjadi : http://192.168.1.2/openwrt (sesuaikan dengan IP PC/Laptop)
    - simpan

    4. lakukan update repo ==>
    root@Openwrt# opkg update

    5. SELESAI....selanjutnya agan bisa install paket2 seperti biasa
    root@Openwrt# opkg install paket1 paket 2.....dst

    Link:
    http://www.facebook.com/groups/openwrt/doc/395379397169757/

  11. Install Paket:
    - luci-app-p910nd
    - p910nd
    - kmod-usb-printer

    * pastikan driver printer sdh terinstal dengan baik di pc/lapie, dengan ciri2 sdh bs bekerja tanpa kendala apabila dipergunakan secara direct via usb port di pc/lapie.

    stlh itu, lakukan tahap2 berikut ini:

    1. tambahkan baris berikut, ke "/etc/config/firewall"
    -----------------------------------------------------
    config rule
    option src br-lan
    option proto tcp
    option dest_port 9100 option target ACCEPT

    -----------------------------------------------------

    2. edit file "/etc/config/p910nd". menjadi :
    -----------------------------------------------------
    config p910nd
    option device '/dev/lp0'
    option port '0'
    option bidirectional '1'
    option enabled '1'

    -----------------------------------------------------

    3. pada windows xp(windows 7 ane gx tau :D)
    klik "start> printers and faks>" selanjutnya klik "file>server Properties>port>add port>standart TCP/IP port>Next"
    isi kolom:
    "printer name or IP Address" = "192.168.1.1" >> "next"

    selanjutnya klik "custom>setting"
    pastikan tab "protocol" yg terpilih "raw" dan  "port number=9100"
    selanjutnya, klik "next>finish>close"


    4. klik "start> printers and faks> add printer>next"
    selanjutnya, pilih "Local printer attached to this computer"
    hilangkan checklist pada "automatically.........", klik "next"
    selanjutnya klik "use the following port" dan pilih port yg "IP_192.168.1.1.....), klik next

    kita sekarang berada pada "Add Printer Wizard" klik "Have disk>browse"
    krn ane menggunakan "EPSON R230x", ane pilih file di "C:\Program File\EPSON\PrinterDriverTmp\SPR230\E_DF1AIP_ENGLISH.INF" lalu klik "OK"
    klik"EPSON......." pada kolom "printers" laluklik "next"
    klik "keep existing driver....", klik "next", lalu tulis nama printer terserah agan.
    pada "do you wantto use.....", pilih "yes", lalu "next>next"
    pada "do you want to print a test page?", klik "yes", lalu "next>finish>OK"
    jika printer merespon, maka agan berhasil.

    Screenshoot hasil:
    http://www.facebook.com/photo.php?fbid=185685044885656&set=o.343581962349501&type=1&ref=nf

    FINISH!!!


    Search Topic:
    http://www.facebook.com/groups/openwrt/search/?query=print%20server

    Referensi:
    http://eko.one.pl/?p=openwrt-printserwer
    http://wiki.openwrt.org/doc/howto/printer.overview
    http://wiki.openwrt.org/doc/howto/p910nd.server
    http://wiki.openwrt.org/doc/howto/cups.server
    http://en.wikipedia.org/wiki/Common%20Unix%20Printing%20System
    http://wiki.openwrt.org/doc/howto/cifs.server
    http://blog.jameslick.com/?p=867

    Link:
    http://www.facebook.com/groups/openwrt/doc/373699406004423/

  12. 1. Buat file tester.sh di /bin
    root@OpenWrt:~# vi /bin/tester.sh
    isinya: tekan i
    #!/bin/sh
    if ! ping -q -c 3 -W 10 8.8.8.8 > /dev/null; then
    (ifup wan) &
    fi
    simpan :tekan Esc lalu tekan wq:
    root@OpenWrt:~#

    2. Menyiapkan tester di cron
    root@OpenWrt:~#touch /bin/tester.sh
    root@OpenWrt:~#chmod 755 /bin/tester.sh
    root@OpenWrt:~#/etc/init.d/cron stop
    root@OpenWrt:~#echo "*/2 * * * * /bin/tester.sh" >> /etc/crontabs/root
    root@OpenWrt:~# /etc/init.d/cron enable
    root@OpenWrt:~# /etc/init.d/cron start

    3. Cek di luci

    Link:
    http://www.facebook.com/groups/openwrt/doc/343634722344225/

  13. Download disini:
    http://winscp.net/eng/download.php

    Bikin profile (NEW) dan isikan parameternya, sbb:
    hostname: 192.168.1.1 (IP Router)
    Port: 22
    Protocol: SCP
    user: root
    pass: *****

    Link:
    http://www.facebook.com/groups/openwrt/doc/343670425673988/

  14. +====================+
    TAMBAHAN DG METODE SWITCH
    + Firmware UNLEASHED sudah tertanam driver ARDUINO
    + tambahan code untuk respon selain untuk monitor jg dpt digunakan untuk status.
    + status gui dpt dilakukan dg l/uci+cgi
    + speed serial menggunakan highspeed 115200 (ganti sendiri jg menggunakan divais low speed)
    +====================+
    + Cindy.Wijaya+
    +====================+

    I. Kode Arduino 
    void setup() {
     Serial.begin(115200); //menggunakan highspeed transfer
     for (int thisPin = 2; thisPin < 7; thisPin++) {
      pinMode(thisPin, OUTPUT); //inisialisasi pin LED
     } }

    void loop() {
     if (Serial.available() > 0) {   int inByte = Serial.read(); //baca serial port

      switch (inByte) {
      case 'a':  
       digitalWrite(2, LOW);
       Serial.print("led 2 MATI");
       break;
      case 'b':  
       digitalWrite(3, LOW);
       Serial.print("led 3 MATI");
       break;
      case 'c':  
       digitalWrite(4, LOW);
       Serial.print("led 4 MATI");
       break;
      case 'd':  
       digitalWrite(5, LOW);
       Serial.print("led 5 MATI");
       break;
      case 'e':  
       digitalWrite(6, LOW);
       Serial.print("led 6 MATI");
       break;
      case 'z':
       for (int thisPin = 2; thisPin < 7; thisPin++) {
        digitalWrite(thisPin, LOW);
       }
       Serial.print("Semua MATI");
       break;
      case 'A':  
       digitalWrite(2, HIGH);
       Serial.print("led 2 NYALA");
       break;
      case 'B':  
       digitalWrite(3, HIGH);
       Serial.print("led 3 NYALA");
       break;
      case 'C':  
       digitalWrite(4, HIGH);
       Serial.print("led 4 NYALA");
       break;
      case 'D':  
       digitalWrite(5, HIGH);
       Serial.print("led 5 NYALA");
       break;
      case 'E':  
       digitalWrite(6, HIGH);
       Serial.print("led 6 NYALA");
       break;
      case 'Z':
       for (int thisPin = 2; thisPin < 7; thisPin++) {
        digitalWrite(thisPin, HIGH);
       }
       Serial.print("Semua NYALA");
       break;
      }
     }
    }

    II. Cara Eksekusi di Openwrt:
    A. Semua Nyala
    root@OpenWrt:~# echo 2 > /dev/ttyUSB0


  15. Pengantar
    MiniDLNA is server software with the aim of being fully compliant with DLNA/UPnP clients. The MiniDNLA daemon serves media files (music, pictures, and video) to clients on a network. Example clients include applications such as totem and xbmc, and devices such as portable media players, Smartphones, Televisions, and gaming systems (such as PS3 and Xbox 360).
    MiniDLNA is a simple, lightweight alternative to MediaTomb, but has fewer features. It does not have a web interface for administration and must be configured by editing a text file.

    Installasi:
    root@OpenWrt:~# opkg update
    root@OpenWrt:~# opkg install minidlna
    instalasi selesai!

    Konfigurasi:
    edit file:
    /etc/minidlna.conf
    atau
    /etc/config/minidlna.conf
    atau
    /tmp/minidlna.conf
    tergantung versi miniDLNA yg anda gunakan

    menjadi seperti ini:
    #------------------------------------#
    #port yg digunakan media
    port=8200
    #interface network yg digunakan
    network_interface=br-lan

    # direktori media, sesuaikan kondisi storage masing-masing.
    # keterangan A = audio, P = picture, V = Video, B = browse direktori, . = generic


    media_dir=A,/mnt/sda1/music
    media_dir=P,/mnt/sda1/picture
    media_dir=V,/mnt/sda1/video

    #nama server
    friendly_name=My DLNA Server

    #lokasi dbcache
    db_dir=/mnt/sda1/minidlna/db

    #lokasi logfile
    log_dir=/mnt/sda1/minidlna/log

    #album art
    album_art_names=Cover.jpg/cover.jpg/AlbumArtSmall.jpg/albumartsmall.jpg/AlbumArt.jpg/albumart.jpg/Album.jpg/album.jpg/Folder.jpg/folder.jpg/Thumb.jpg/thumb.jpg

    #dst
    inotify=yes
    enable_tivo=no
    strict_dlna=no
    presentation_url=http://192.168.1.1:8200/
    notify_interval=900
    serial=12345678
    model_number=1 #------------------------------------#

    Jalankan Daemon:
    root@OpenWrt:~# /etc/init.d/minidlna enable
    root@OpenWrt:~# /etc/init.d/minidlna start
    Selesai!

    Hasilnya dapat dinikmati melalui:..."Example clients include applications such as totem and xbmc, and devices such as portable media players, Smartphones, Televisions, and gaming systems (such as PS3 and Xbox 360), etc"

    Referensi:
    http://wiki.openwrt.org/doc/uci/minidlna
    https://wiki.archlinux.org/index.php/MiniDLNA
    http://www.facebook.com/media/set/?set=oa.424511727589857&type=1
    http://klseet.com/index.php?option=com_content&view=article&id=148&Itemid=128

    Link:
    http://www.facebook.com/groups/openwrt/doc/424550050919358/

  16. MEMBIKIN EXROOT
    Pembuatan exroot ini menggunakan fw-mang v.1
    untuk beberapa firmware yg sudah diindikasikan instalasi paket & driver tidak diperlukan. Tutorial ini jika menggunakan fw-mang v.1 atau firmware yg msh kosongan dan/atau +luci saja.

    I. Mempersiapkan modul yg dibutuhkan (belum include di fw v.1)
    block-mount
    kmod-usb-storage
    kmod-fs-ext4 -> untuk yg menggunakan EXT2, EXT3, EXT4

    II. Melakukan Partisi Flasdisk/mSD/MMC/Other Media (termasuk hardisk jk ingin menggunakan hardisk [transfer lbh cpt])
    Partisi I (format: Linux Swap, ukuran kecil aja 100MB jg boleh)
    Partisi II (format: EXT2 = untuk removable disk, EXT3 = removable IDE, EXT4 = disk besar)

    Cara partisi:
    1. Menggunakan OpenWRT
    menggunakan perintah fdisk(fdisk required)
    format menggunakan perintah mke2fs (e2fsprogs required)
    2. Menggunakan GParted/utilitas lainya
    atau lht tutor dari Om Budi, disini:
    http://www.budiarno.co.tv/2011/06/extroot-openwrt.html

    III. Edit fstab
    Lokasi: /etc/config/fstab
    config 'global' 'automount'
    option 'from_fstab' '1'
    option 'anon_mount' '1'
    config 'global' 'autoswap'
    option 'from_fstab' '1'
    option 'anon_swap' '0'
    config 'mount'
    option 'fstype' 'ext2'
    option 'options' 'rw,sync'
    option 'enabled' '1'
    option 'device' '/dev/sdb2'
    option 'target' '/mnt/sdb2'
    config 'swap'
    option 'device' '/dev/sdb1'
    option 'enabled' '1'

    IV. Jalankan FSTAB
    a) Membikin fstab start at reboot
    root@OpenWrt:~# /etc/init.d/fstab enable

    b) Menjalankan fstab
    root@OpenWrt:~# /etc/init.d/fstab start

    Pada tahap ini Flashdisk siap digunakan, akan tampak sbb:
    Filesystem Size Used Available Use% Mounted on
    /dev/root 1.9M 1.9M 0 100% /rom
    tmpfs 14.4M 88.0K 14.3M 1% /tmp
    tmpfs 512.0K 0 512.0K 0% /dev
    /dev/mtdblock3 576.0K 68.0K 508.0K 12% /overlay
    overlayfs:/overlay 576.0K 68.0K 508.0K 12% /
    /dev/sda2 1.7G 13.4M 1.6G 1% /mnt/sda2

    kalau fdisk sudah dpt ter-mount spt gambar diatas maka dpt lsg dilakukan proses produksi exroot sbb:

    V. Transfer System ke Flashdisk
    Jalankan Perintah di bahwah ini:
    tar -C /overlay -cvf - . | tar -C /mnt/sdb2 -xf -
    mkdir -p /tmp/cproot
    mount --bind / /tmp/cproot
    tar -C /tmp/cproot -cvf - . | tar -C /mnt/sdb2 -xf -
    umount /tmp/cproot

    Setelah selesai, kembali edit file fstab, menjadi:

    VI. Edit konfigurasi fstab menjadi rootfs.
    config 'global' 'automount'
    option 'from_fstab' '1'
    option 'anon_mount' '1'
    config 'global' 'autoswap'
    option 'from_fstab' '1'
    option 'anon_swap' '0'
    config 'mount'
    option 'fstype' 'ext2'
    option 'options' 'rw,sync'
    option 'enabled' '1'
    option 'device' '/dev/sdb2'
    option 'is_rootfs' '1'
    config 'swap'
    option 'device' '/dev/sdb1'
    option 'enabled' '1'

    VII. Reboot

    VIII. Selamat Menikmati ;)

    Link:
    http://www.facebook.com/groups/openwrt/doc/343770922330605/



  17. kemarin2 waktu masih pake luci troubleshootnya enak, tinggal masuk ke kernel log / system log.nah untuk mode text/cli gimana yah ?
    setelah iseng2 tanya2 mbah google, akhirnya nemu juga nih.kalo di linux sih
    pake command: tail -f /var/log/message

    nah kalo di openwrt kita bisa pake command

    # logread

    link
    http://www.facebook.com/groups/openwrt/doc/343639939010370/

  18. Package: 'microcom' (atau yg sejenis: minicom, dsb)
    1. panggil modem dengan cara "microcom -D/dev/ttyUSB2"
    2. pas keluar angka angka gak jelas switch modem ke edge dengan cara copas "AT^SYSCFG=13,1,3FFFFFFF,1,2" tanpa tanda petik dan tekan enter
    3. masuk ke network > interface > reconnect this interface di bagian wan
    4. liat sampe dapet ip kalo enggak liat di modem biasanya nyala ijo
    5. setelah konek copas ini "AT^SYSCFG=14,2,3FFFFFFF,1,2" tanpa tanda petik lalu tekan enter


    link:
    http://www.facebook.com/groups/openwrt/doc/343633652344332/

  19. Buat maen game online tapi NAT mode : STRICT (xbox360 & PS3)..

    install  
    opkg update
    opkg install miniupnpd

    buat auto & trigger pada saat boot :
    root@OpenWrt# /etc/init.d/miniupnpd enable
    root@OpenWrt# /etc/init.d/miniupnpd start

    NAT type nya langsung OPEN...

    Warning 
    hanya aktifkan jika main game online saja, kalo untuk browsing deactive lagi cos semua port otomatis terbuka..cheers

    link:
    http://www.facebook.com/groups/openwrt/doc/343639545677076/

  20. Membuat full backup image openwrt dari Router Aktif (cloning image)
    ketika kita telah cape install berbagai packet ke router openwrt, dan router udah ready online. namun ketika di tengah-tengah ada gagal seting, maka kita harus flash dari awal, ato reset menggunakan command "firstboot".

    adakah cara lain untuk menyelamatkan image yang telah terinstall berbagai packet yang dibutuhkan, seperti Luci web interface + driver USB modem dll.
    awalnya saya tidak yakin menggunakan cara ini, masih bimbang antara router jadi brick atau "on sesuai harapan"
    openwrt menyimpan Firmware pada "mtd5" atau tempat menyimpan image yg kita flash ke router ternyata di mtd5. setelah di install berbagai packet-packet juga akan di masukan ke mtd5.
    langkah membackupnya bisa login ke router menggunakan command:
    +--------------------------------------+
    I. Backup Firmware
    +--------------------------------------+
    cat /dev/mtd5 > /tmp/factory.bin

    langkah di atas membuat backup full firmware ke:
    file "factory.bin"
    dan disimpan
    ke folder "/tmp"
    simpanlah file image baru tersebut baik-baik di PC. untuk flash ke router kembali, seperti flash image standar saja. bisa upgrade dari Webinterface atau menggunakan winscp untuk copy image ke "/tmp" lalu login pake putty lakukan perintah


    +--------------------------------------+
    II. Restore Firmware
    +--------------------------------------+

    cd /tmp && mtd -e firmware -r write factory.bin firmware

    Link:
    http://www.facebook.com/groups/openwrt/doc/343768642330833/

  21. The rule below redirects all outgoing HTTP traffic from lan through a proxy server listening at port 3128 on the router itself.

    config redirect
    option src lan
    option proto tcp
    option src_dport 80
    option dest_port 3128

    The following rule redirects all outgoing HTTP traffic from lan through an external proxy at 192.168.1.100 listening on port 3128.

    config redirect
    option src lan
    option proto tcp
    option src_ip !192.168.1.100
    option src_dport 80
    option dest_ip 192.168.1.100
    option dest_port 3128
    option target DNAT

    config redirect
    option dest lan
    option proto tcp
    option src_dip 192.168.1.1
    option dest_ip 192.168.1.100
    option dest_port 3128 option target SNAT


    Source:
    http://wiki.openwrt.org/doc/uci/firewall

    Link:
    http://www.facebook.com/groups/openwrt/doc/343637139010650/

  22. Attach functions to the hardware button
    FIXME part of this article is not done.
    Check the article wifitoggle. If you want, you can rewrite this.
    Some more inspiration: buttons TODO
    nslu2.hardware.button for the NSLU2

    Configuring buttons
    Preliminary steps The first step is to find out the internal name of the button you want to use: some images use generic names such as BTN_1, BTN_2, others have more specific ones like reset, wps, etc. Run the following:
    # mkdir -p /etc/hotplug.d/button
    Create the file /etc/hotplug.d/button/buttons with your favorite text editor, paste the following:

    #!/bin/sh
    logger $BUTTON logger $ACTION
    Save and exit. Now press the button you want to use, then run logread.

    Jan 1 00:01:15 OpenWrt user.notice root: BTN_1
    Jan 1 00:01:15 OpenWrt user.notice root: pressed
    Jan 1 00:01:16 OpenWrt user.notice root: BTN_1 Jan 1 00:01:16 OpenWrt user.notice root: released

    BTN_1 is the name of the button you want to use. If you want or need to use another button, replace every instance of BTN_1 in the rest of this document with the correct text. From now on, there are several possible approaches: the first uses the 00-button script from the atheros target, the other a simpler shell script.

    Using Atheros' 00-button + UCI
    If you've installed the full version of wget, run the following:
    # wget -O /etc/hotplug.d/button/00-button http://dev.openwrt.org/export/21216/trunk/target/linux/atheros/base-files/etc/hotplug.d/button/00-button
    If you only have wget-nossl and don't want to or can't upgrade, create
    /etc/hotplug.d/button/00-button

    with your favorite editor, then paste the following:
    . /etc/functions.sh
    do_button () {
    local button
    local action
    local handler
    local min
    local max

    config_get button $1 button
    config_get action $1 action
    config_get handler $1 handler
    config_get min $1 min config_get max $1 max

    [ "$ACTION" = "$action" -a "$BUTTON" = "$button" -a -n "$handler" ] && {
    [ -z "$min" -o -z "$max" ] && eval $handler
    [ -n "$min" -a -n "$max" ] && {
    [ $min -le $SEEN -a $max -ge $SEEN ] && eval $handler
    }
    }
    }

    config_load system config_foreach do_button button

    Save and exit, then issue these commands:
    uci add system button
    uci set system.@button[-1].button=BTN_1
    uci set system.@button[-1].action=pressed
    uci set system.@button[-1].handler='logger BTN_1 pressed' uci commit system

    button is the name as the button, action is the event (two values: pressed and released), handler contains the command line to be run when the event is detected (can be a script as well).
    You may need to reboot the router the make the change effective (mine would work with the simple shell script just fine but wouldn't budge when using the 00-button script — Frex 2011/03/25 22:29). If this works, you can change the handler to something more useful, and add more button handlers.

    Examples Example 1: Toggle Wi-Fi radio with a button press
    uci add system button
    uci set system.@button[-1].button=wps
    uci set system.@button[-1].action=pressed
    uci set system.@button[-1].handler='uci set wireless.@wifi-device[0].disabled=1 && wifi' uci commit system
    Example 2: Assign two different functions to the same button: short press VS long press. This relies on tracking the released event rather than the pressed event.
    uci add system button
    uci set system.@button[-1].button=BTN_1
    uci set system.@button[-1].action=released
    uci set system.@button[-1].handler='logger timed pressed: 0-3s'
    uci set system.@button[-1].min=0
    uci set system.@button[-1].max=3
    uci add system button
    uci set system.@button[-1].button=BTN_1
    uci set system.@button[-1].action=released
    uci set system.@button[-1].handler='logger timed pressed: 8-10s'
    uci set system.@button[-1].min=8
    uci set system.@button[-1].max=10 uci commit system

    Example 3: Unmount USB storage using a long-ish press
    uci add system button
    uci set system.@button[-1].button=BTN_1
    uci set system.@button[-1].action=released
    uci set system.@button[-1].handler="for i in \$(mount | awk '/dev\/sd[b-z]/ { print \$1}'); do umount \$i; done"
    uci set system.@button[-1].min=5
    uci set system.@button[-1].max=10 uci commit system
    Example 4: Restore defaults
    config button
    option button reset
    option action released
    option handler "firstboot && reboot"
    option min 5 option max 30

    Example 5: Toggle Wi-Fi using a script
    config button
    option button wps
    option action released
    option handler "/usr/bin/wifionoff"
    option min 0 option max 3
    You'll have to create the file /usr/bin/wifionoff and paste this:
    #!/bin/sh
    SW=$(uci -q get wireless.@wifi-device[0].disabled)
    [ "$SW" == "1" ] && uci set wireless.@wifi-device[0].disabled=0
    [ "$SW" == "1" ] || uci set wireless.@wifi-device[0].disabled=1 wifi

    Example 6: Set transmission-daemon alt-speed, enable or disable.Short press will activate alt-speed or longer press will deactivate alt-speed and also turns on qss led about speed status on tl-wr1043nd
      Edit your alt-speed limits from transmission-daemon , settings.json file.To execute script, you need to install transmission-remote package from opkg.

    uci add system button
    uci set system.@button[-1].button=BTN_1
    uci set system.@button[-1].action=pressed
    uci set system.@button[-1].handler='transmission-remote -as'
    uci add system button
    uci set system.@button[-1].button=BTN_1
    uci set system.@button[-1].action=pressed
    uci set system.@button[-1].handler='echo 1 > /sys/class/leds/tl-wr1043nd:green:qss/brightness'
    uci add system button
    uci set system.@button[-1].button=BTN_1
    uci set system.@button[-1].action=released
    uci set system.@button[-1].handler='transmission-remote -AS'
    uci set system.@button[-1].min=1
    uci set system.@button[-1].max=4
    uci add system button
    uci set system.@button[-1].button=BTN_1
    uci set system.@button[-1].action=released
    uci set system.@button[-1].handler='echo 0 > /sys/class/leds/tl-wr1043nd:green:qss/brightness'
    uci set system.@button[-1].min=1
    uci set system.@button[-1].max=4 uci commit system

    Reference:
    http://wiki.openwrt.org/doc/howto/hardware.button

    Link:
    http://www.facebook.com/groups/openwrt/doc/343766725664358/

  23. Tuning Dnsmasq
    Gan..kalo agan sedang asik "ngebros" pernah gak terasa lelet ? apalagi kalo buka situs gak beres , kalo lancar-lancar aza rasanya ini gak guna buat agan.
    Banyak faktor penyebab lelet, salah satunya dns server agan yg di openwrt itu gak responsif, padahal ane dah pake kartu "I hate slow", pake doping pula.
    Coba agan test pake "dig" (opkg install bind-dig)
    Code:
    root@OpenWrt:~# dig icann.org | grep "Query time"
    ;; Query time: 254 msec
    root@OpenWrt:~# dig icann.org | grep "Query time" ;; Query time: 2 msec

    Query pertama 254 msec setelah tercache query kedua hanya butuh 2msec. Sebelum ane tuning paling mentok di 35 msec, tuningnya sederhana aja gan.
    Edit /etc/config/dhcp
    Code:
    config dnsmasq
    option domainneeded 1
    option boguspriv 1
    option filterwin2k 0
    option localise_queries 1
    option rebind_protection 1
    option rebind_localhost 1
    option local '/lan/'
    option domain 'lan'
    option expandhosts 1
    option nonegcache 0
    option authoritative 1
    option interface lan
    option cachesize 500
    option readethers 1
    option leasefile '/tmp/dhcp.leases' option resolvfile '/etc/resolv.conf'
    Edit /etc/resolv.conf
    Code:
    search lan
    nameserver 127.0.0.1
    nameserver 180.131.144.144 nameserver 180.131.145.145
    Code: :~#/etc/init.d/dnsmasq restart


    Referensi:
    https://wiki.archlinux.org/index.php/Dnsmasq
    http://wiki.openwrt.org/doc/uci/dhcp
    http://community.linuxmint.com/tutorial/view/489
    http://www.kaskus.co.id/showpost.php?p=593310174&postcount=1647

    Link:
    http://www.facebook.com/groups/openwrt/doc/343761228998241/

  24. I. MELIHAT DAFTAR CHANNEL WIFI YANG TERSEDIA

    Perintah:
    root@OpenWrt:~# iwlist wlan0 channel

    contoh hasil:
    wlan0 14 channels in total; available frequencies :
    Channel 01 : 2.412 GHz
    Channel 02 : 2.417 GHz
    Channel 03 : 2.422 GHz
    Channel 04 : 2.427 GHz
    Channel 05 : 2.432 GHz
    Channel 06 : 2.437 GHz
    Channel 07 : 2.442 GHz
    Channel 08 : 2.447 GHz
    Channel 09 : 2.452 GHz
    Channel 10 : 2.457 GHz
    Channel 11 : 2.462 GHz
    Channel 12 : 2.467 GHz
    Channel 13 : 2.472 GHz
    Channel 14 : 2.484 GHz Current Frequency=2.417 GHz (Channel 2)
    ~ஜ۩۞۩ஜ

    II. MEMATIKAN DAN MENYALAKAN WIFI
    A) Metode CLI
    Ingin mengaktifkan wifi dengan mode CLI , edit fi;e /etc/config/wireless

    # REMOVE THIS LINE TO ENABLE WIFI:
    option disabled 1

    tinggal di comment dengan menempatkan # didepan option , setelah itu jalankan perintah:
    root@OpenWrt:~# wifi

    Usage: /sbin/wifi [down|detect]
    enables (default), disables or detects a wifi configuration.

    untuk mendisable wifi tinggal buka aja comment yang sebelumnya dibuat dan jalankan ulang command wifi tadi untuk mendisable wifi.
    *****************************************************
    B) Metode UCI
    root@OpenWrt:~# uci set wireless.@wifi-device[0].disabled=1
    root@OpenWrt:~# uci commit wireless
    root@OpenWrt:~# wifi

    Keterangan:
    1) device[0] : device wifi pertama, jika ada beberapa wifi tambahan misalnya usbwifi maka dpt menggunakan device[1], device[2], dst.
    2) untuk firmware unleashed sudah ditanamkan di dalam firmware. untuk mengaktifkan dan mematikan wifi tekan tombol QSS selama 0-3 detik, untuk mengaktifkan/mematikan wifi kedua (usbwifi) tekan tombol QSS 4-30 detik.

    link:
    http://www.facebook.com/groups/openwrt/doc/343758522331845/

  25. STEP BY STEP SETTING 3G MULTIWAN DI OPENWRT
    Keyword: multi wan dual modem koneksi

    ALAT & BAHAN
    - Router yg ane gunakan adalah huawei hg553
    - Modem yg ane gunakan adalah vodafone/huawei k3715 & huawei e153
    - Kartu yg digunakan keduanya tekomsel flash
    - USB HUB abal2 kisran harga 10-15rb :hammers (kabel sudah diganti untuk menghindari daya yg kurang pada USB HUB, sehingga tidak perlu mempergunakan adaptor untuk menambah daya di USB HUB :) )

    ane yakin bs juga di terapkan pada semua roter dengan syarat
    1. firmware yg digunakan openwrt
    2. ada slot USB dengan USB HUB
    3. 2 modem bs langsung terdeteksi dengan baik tanpa perintah tambahan.

    langsung aja ya tanpa basa basi

    PERSIAPAN
    back up dulu firmware/config yg ada sekarang, menghindari gagal setting

    TAHAP PERTAMA
    ruba file di /etc/confg/network menjadi


    network
    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config interface 'lan'
    option type 'bridge'
    option ifname 'eth1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

    config interface 'wan'
    option proto '3g'
    option service 'umts'
    option apn 'internet'
    option username ' '
    option password ' '
    option device '/dev/ttyUSB0'
    option defaultroute '0'
    option maxwait '20'

    config interface 'wan2'
    option proto '3g'
    option device '/dev/ttyUSB4'
    option service 'umts'
    option apn 'internet'
    option username ' '
    option password ' '
    option defaultroute '0'
    option maxwait '10'

    config 'switch'
    option 'name' 'rtl8366s'
    option 'reset' '1'
    option 'enable_vlan' '1'
    option 'blinkrate' '2'

    config 'switch_vlan'
    option 'device' 'rtl8366s'
    option 'vlan' '1'
    option 'ports' '0 1 2 3 5t'

    config 'switch_port'
    option 'device' 'rtl8366s'
    option 'port' '1'
    option 'led' '6'

    config 'switch_port'
    option 'device' 'rtl8366s'
    option 'port' '2'

    config 'switch_port'
    option 'device' 'rtl8366s'
    option 'port' '5'

    TAHAP KEDUA
    rubah file /etc/config/multiwan menjadi:

    multiwan
    config 'multiwan' 'config'
    option 'health_monitor' 'serial'
    option 'default_route' 'fastbalancer'
    option 'debug' '1'

    config 'interface' 'wan'
    option 'health_fail_retries' '3'
    option 'health_recovery_retries' '5'
    option 'failover_to' 'fastbalancer'
    option 'timeout' '10'
    option 'dns' '8.8.8.8 8.8.4.4'
    option 'weight' '10'
    option 'health_interval' '120'
    option 'icmp_hosts' 'gateway'

    config 'interface' 'wan2'
    option 'timeout' '3'
    option 'health_fail_retries' '3'
    option 'health_recovery_retries' '5'
    option 'failover_to' 'fastbalancer'
    option 'dns' '208.67.222.222 208.67.220.220'
    option 'weight' '10'
    option 'health_interval' '120'
    option 'icmp_hosts' 'gateway'

    config 'mwanfw'
    option 'src' '192.168.1.150'
    option 'wanrule' 'fastbalancer'

    config 'mwanfw'
    option 'wanrule' 'fastbalancer'

    TAHAP KETIGA
    rubah file /etc/config/firewall menjadi:

    firewall
    config 'defaults'
    option 'syn_flood' '1'
    option 'input' 'ACCEPT'
    option 'output' 'ACCEPT'
    option 'forward' 'REJECT'
    option 'drop_invalid' '1'

    config 'zone'
    option 'name' 'lan'
    option 'network' 'lan'
    option 'input' 'ACCEPT'
    option 'output' 'ACCEPT'
    option 'forward' 'REJECT'

    config 'zone'
    option 'name' 'wan'
    option 'input' 'REJECT'
    option 'output' 'ACCEPT'
    option 'forward' 'REJECT'
    option 'masq' '1'
    option 'mtu_fix' '1'
    option 'network' 'wan'

    config 'rule'
    option 'src' 'wan'
    option 'proto' 'udp'
    option 'dest_port' '68'
    option 'target' 'ACCEPT'
    option 'family' 'ipv4'

    config 'rule'
    option 'src' 'wan'
    option 'proto' 'icmp'
    option 'icmp_type' 'echo-request'
    option 'family' 'ipv4'
    option 'target' 'ACCEPT'

    config 'rule'
    option 'src' 'wan'
    option 'proto' 'icmp'
    list 'icmp_type' 'echo-request'
    list 'icmp_type' 'destination-unreachable'
    list 'icmp_type' 'packet-too-big'
    list 'icmp_type' 'time-exceeded'
    list 'icmp_type' 'bad-header'
    list 'icmp_type' 'unknown-header-type'
    list 'icmp_type' 'router-solicitation'
    list 'icmp_type' 'neighbour-solicitation'
    option 'limit' '1000/sec'
    option 'family' 'ipv6'
    option 'target' 'ACCEPT'

    config 'rule'
    option 'src' 'wan'
    option 'dest' '*'
    option 'proto' 'icmp'
    list 'icmp_type' 'echo-request'
    list 'icmp_type' 'destination-unreachable'
    list 'icmp_type' 'packet-too-big'
    list 'icmp_type' 'time-exceeded'
    list 'icmp_type' 'bad-header'
    list 'icmp_type' 'unknown-header-type'
    option 'limit' '1000/sec'
    option 'family' 'ipv6'
    option 'target' 'ACCEPT'

    config 'include'
    option 'path' '/etc/firewall.user'

    config 'forwarding'
    option 'dest' 'wan'
    option 'src' 'lan'

    config 'rule'
    option 'target' 'ACCEPT'

    config 'zone'
    option 'name' 'wan2'
    option 'forward' 'REJECT'
    option 'output' 'ACCEPT'
    option 'network' 'wan2'
    option 'input' 'REJECT'
    option 'masq' '1'
    option 'mtu_fix' '1'

    config 'forwarding'
    option 'dest' 'wan2'
    option 'src' 'lan'
    TAHAP KE EMPAT
    rubah file /etc/config/dhcp
    dhcp
    config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'

    config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    list dhcp_option '6,208.67.222.222,208.67.220.220'

    config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

    TAHAP KE LIMA
    masuk ke "putty"

    - Buat file, dengan perintah:

    # touch /bin/tester.sh
    # chmod 755 /bin/tester.sh

    - copas tulisan di bawah ini ke dalam file /bin/tester.sh

    tester.sh
    #!/bin/sh
    if ! ping -q -c 1 -W 10 -I 3g-wan 8.8.8.8 > /dev/null; then
    (ifup wan; sleep 5; /etc/init.d/multiwan restart) &
    fi

    if ! ping -q -c 1 -W 10 -I 3g-wan2 8.8.8.8 > /dev/null; then
    (ifup wan2; sleep 5; /etc/init.d/multiwan restart) &
    fi

    kembali masuk ke "putty"
    - ketik perintah:

    # /etc/init.d/cron stop
    # echo "*/2 * * * * /bin/tester.sh" >> /etc/crontabs/root
    # /etc/init.d/cron enable
    # /etc/init.d/cron start

    SELESAI...............

    # silahkan ubah config di atas sesuaikan dengan jenis roter, ISP yg dpergunakan dan posisi terdeteksinya modem di router
    # untuk failover silakan edit config yg sesuai.

    Referensi:
    http://wiki.openwrt.org/doc/recipes/3gdongle

Artikel Terkait

Next Article
« Prev Post
Previous Article
Next Post »
Penulisan markup di komentar
  • Untuk menulis huruf bold gunakan <strong></strong> atau <b></b>.
  • Untuk menulis huruf italic gunakan <em></em> atau <i></i>.
  • Untuk menulis huruf underline gunakan <u></u>.
  • Untuk menulis huruf strikethrought gunakan <strike></strike>.
  • Untuk menulis kode HTML gunakan <code></code> atau <pre></pre> atau <pre><code></code></pre>, dan silakan parse kode pada kotak parser di bawah ini.

Disqus
Tambahkan komentar Anda

2 comments

Master2... mau nanya... maaf sebelumnya saya masih awam di bidang IT...
Bisa gak ya kalau kita mau ngeremote Router melalui jaringan internet...? misal alat yg ad d luar area :
Modem-->Router Tp-Link 3420 (Openwrt)-->server/CCTV/perangkat berbasis Ip,dll...
Monggok coretannya Om...

Balas

om, klo interfece wifi sama lannya terhapus gmn solusinya? tks

Balas